Задан двумерный массив А из 2-х строк и 7-и столбцов. Составить программу, которая организует одномерный массив, каждый элемент которого есть сумма элементов исходного в столбце.
Помоги мне, пожалуйста! Пожалуйста, напишите полную программу для меня ... Большое вам спасибо за помощь!!!
Answers & Comments
var a:array[1..2,1..7] of integer;
b:array[1..7] of integer;
i,j,s:integer;
begin
for i:=1 to 2 do
begin
for j:=1 to 7 do
begin
a[i,j]:=random(10);
write (a[i,j]:2,' ')
end;
writeln
end;
writeln;
for j:=1 to 7 do
begin
s:=0;
for i:=1 to 2 do s:=s+a[i,j];
b[j]:=s;
end;
for i:=1 to 7 do write (b[i]:2,' ')
end.