Задан двумерный массив Y из 4-х строк и 4-х столбцов. Составить программу, которая вычисляет S – сумму элементов побочной диагонали и значение суммы всех элементов массива
На с++ подробне пожалуйста эту задачу я не понял что то
Answers & Comments
Nove1990
#include <iostream> #include <iomanip> int main() { using namespace std; const int N = 4; const int M = 4; int Y[N][M];
//как-нибудь заполняем матрицу for (int i = 0; i < N; ++i) for (int j = 0; j < M; ++j) Y[i][j] = (i + 1) * (j + 1);
//выведем её на экран for (int i = 0; i < N; ++i) { for (int j = 0; j < M; ++j) cout << setw(3) << Y[i][j]; cout << endl; }
//находим сумму элементов побочной диагонали int S = 0; for (int i = 0; i < N; ++i) for (int j = 0; j < M; ++j) if (j == M - 1 - i) S = S + Y[i][j]; cout << "Sum of adverse diagonal of array: " << S << endl;
//находим сумму всех элементов матрицы int Sum = 0; for (int i = 0; i < N; ++i) for (int j = 0; j < M; ++j) Sum = Sum + Y[i][j]; cout << "Sum of all elements of array: " << Sum << endl; return 0; }
Answers & Comments
#include <iomanip>
int main()
{
using namespace std;
const int N = 4;
const int M = 4;
int Y[N][M];
//как-нибудь заполняем матрицу
for (int i = 0; i < N; ++i)
for (int j = 0; j < M; ++j)
Y[i][j] = (i + 1) * (j + 1);
//выведем её на экран
for (int i = 0; i < N; ++i)
{
for (int j = 0; j < M; ++j)
cout << setw(3) << Y[i][j];
cout << endl;
}
//находим сумму элементов побочной диагонали
int S = 0;
for (int i = 0; i < N; ++i)
for (int j = 0; j < M; ++j)
if (j == M - 1 - i)
S = S + Y[i][j];
cout << "Sum of adverse diagonal of array: " << S << endl;
//находим сумму всех элементов матрицы
int Sum = 0;
for (int i = 0; i < N; ++i)
for (int j = 0; j < M; ++j)
Sum = Sum + Y[i][j];
cout << "Sum of all elements of array: " << Sum << endl;
return 0;
}