Задание 1. Дана программа нахождения суммы и произведения первых 10-и натуральных чисел
Составьте программу нахождения суммы и произведения первых 20-и четных чисел.
program pr_1;
var i, s, p: integer;
begin
s:=0;
p:=1;
for i:=1 to 10 do
begin
s:=s+i;
p:=p*i
end;
writeln ('сумма чисел равна ', s);
writeln ('произведение чисел равно ', p)
end.

program pr_2;
var i, s, p: integer;
begin
s:=0;
p:=1;
i:=1;
while i<=10 do
begin
s:=s+i;
p:=p*i;
i:=i+1
end;
writeln ('сумма чисел равна ', s);
writeln ('произведение чисел равно ', p)
end.

Please enter comments
Please enter your name.
Please enter the correct email address.
You must agree before submitting.

Answers & Comments


рекомендуемые вопросы

Copyright © 2025 SCHOLAR.TIPS - All rights reserved.