Задание 5. Составьте программу, которая генерирует случайное четы- рехзначное число от 1000 до 9999 (номер автобусного билета), выводит его на экран и определяет, является ли билет «счастливым» (сумма первых двух цифр равна сумме последних двух цифр). ВНИМАНИЕ ЯЗЫК ПАСКАЛЬ
Answers & Comments
var
n:integer;
begin
n:=random(9000)+1000;
writeln(n);
if n div 1000 + n div 100 mod 10 = n mod 10 + n mod 100 div 10 then
writeln('Happy ticket')
else writeln('Oooops');
end.