1) Напишите программу, которая вводит трехзначное число и разбивает его на цифры. Пример: при вводе числа 123 программа должна вывести "1, 2, 3"
2) Нужно написать такую же программу как и в первом номере,только для случайных чисел( не для трехзначного числа)
Помогите пожалуйста
Заранее огромнейшее спасибо
Answers & Comments
Verified answer
универсальный вариант. Долго над решением думать не хотелось, так что ответ такой. Поскольку ограничений на решение не было)
//PascalABC.NET версия 3.4.0.1677 от 17.06.18
//Если программа не запускается, то обновите версию
var
n: integer;
s: string;
begin
readln(n);
s := '';
while n > 0 do
begin
s := (n mod 10).ToString() + '0
' + s;
n := n div 10;
end;
writeln(s);
end.