C++
Напишите программу, которая определяет, попадает ли заданная точка в
заштрихованную область. Граничные точки входят в область.
Формат входных данных
Вводится целое число х, которое по модулю не превосходит 105.
Формат выходных данных
Вывести «1», если координаты точки попадают в данную область, и «О» В противном
случае.
Входные данные
выходные данные
1
Answers & Comments
Ответ:
#include <iostream>
#include <cmath>
using namespace std;
int main()
{
int x;
cin >> x;
if (abs(x) <= 105)
{
if (x >= -5 && x <= 1 || x >= 7 && x <=13)
cout << '1';
else
cout << 'O';
}
return 0;
}