На языке Pascal составьте программу вывода на экран номера этажа и номеров квартир, находящихся на данном этаже, для девятиэтажного дома, на каждом этаже которого находится по 5 квартир.
На языке Pascal составьте программу вычисления значения величины b в соответствии с ниже приведённым элементом блок-схемы.
Исходные данные:
а=0, b=0
Answers & Comments
Verified answer
1.var n,i:integer;
begin
write('Этаж = ');
readln(n);
writeln('Квартиры: ');
for i:=1 to 5 do write(5*(n-1)+i,' ');
end.
Пример:
Этаж = 7
Квартиры:
31 32 33 34 35
2.
var a,b:integer;
begin
a:=0; b:=0;
while a<7 do
begin
a:=a+1;
b:=b+a;
end;
writeln('a = ',a,' b = ',b);
end.
Результат:
a = 7 b = 28