На языке паскаль: 1. Проверить, делится ли произведение пяти натуральных чисел на первое из них нацело. 2.Определите количество двузначных чисел, сумма квадратов цифр которых делится без остатка на 15.
Answers & Comments
Maximason
1. uses crt; var a,b,c,d,e,f:integer; begin writeln ('vvedite 5 chisel'); read (a,b,c,d,e); f:=a*b*c*d*e ; if (f mod a)=0 then writeln ('delitsa') else writeln ('nedelitsa'); end.
По поводу второй, не уверен, если под суммой квадратов цифр подразумевается 10 = 1*1+0*0, то эта программа неправильна, её нужно переписать будет. uses crt; var a,i,s,t,t1:integer; begin for i:=10 to 99 do begin t:=i div 10; t1:=i mod 10 ; if (sqr(t)+sqr(t1)) mod 15 = 0 then s:=s+1; end; writeln (s); end.
2 votes Thanks 1
milushaprincess
над второй я еще подумаю,а первую уже решила,но все равно спасибо
Answers & Comments
uses crt;
var a,b,c,d,e,f:integer;
begin
writeln ('vvedite 5 chisel');
read (a,b,c,d,e);
f:=a*b*c*d*e ;
if (f mod a)=0
then writeln ('delitsa')
else writeln ('nedelitsa');
end.
По поводу второй, не уверен, если под суммой квадратов цифр подразумевается 10 = 1*1+0*0, то эта программа неправильна, её нужно переписать будет.
uses crt;
var a,i,s,t,t1:integer;
begin
for i:=10 to 99 do begin
t:=i div 10; t1:=i mod 10 ;
if (sqr(t)+sqr(t1)) mod 15 = 0
then s:=s+1;
end;
writeln (s);
end.