Напишите программу для решения следующей задачи. Ученики 4 класса вели дневники наблюдения за погодой и ежедневно записывали дневную температуру. Найдите самую низкую температуру за время наблюдения. Если температура опускалась ниже –15 градусов, выведите YES, иначе выведите NO. Программа получает на вход количество дней, в течение которых проводилось измерение температуры N (1 ≤ N ≤ 31), затем для каждого дня вводится температура. Пример работы программы:
Входные данные:4 –5 12 –2 8 Выходные данные : –5 NO
Программу написать в C++
Answers & Comments
#include <iostream>
using namespace std;
int main()
{
int N, temp, min_temp = 1000;
cin >> N;
for (int i = 0; i < N; i++) {
cin >> temp;
if (temp < min_temp) {
min_temp = temp;
}
}
cout << min_temp << endl;
if (min_temp < -15) cout << "YES"; else cout << "NO";
}