Напишите программу, которая определяет сколько раз встречается максимальное число в и-той последовательности, ограниченная n значением. При этом каждое вводимое число должно храниться в памяти компьютера.
Answers & Comments
pacixor
//Pascal var A: array of integer; i, n, MAX, tmpCount: integer; begin write('Введите n = '); read(n); SetLength(A, n); MAX := 0; for i := 0 to n-1 do begin write('A[', i+1, '] = '); read(A[i]); if A[i] > MAX then begin tmpCount := 0; MAX := A[i]; tmpCount := tmpCount + 1; end else if A[i] = MAX then tmpCount := tmpCount + 1; end; writeln('Максимальное число ',MAX,' встречается ',tmpCount,' раз.'); readln; end.
Answers & Comments
var
A: array of integer;
i, n, MAX, tmpCount: integer;
begin
write('Введите n = '); read(n);
SetLength(A, n);
MAX := 0;
for i := 0 to n-1 do
begin
write('A[', i+1, '] = ');
read(A[i]);
if A[i] > MAX then
begin
tmpCount := 0;
MAX := A[i];
tmpCount := tmpCount + 1;
end
else
if A[i] = MAX then tmpCount := tmpCount + 1;
end;
writeln('Максимальное число ',MAX,' встречается ',tmpCount,' раз.');
readln;
end.