Напишите программу, которая по введённому числу определит, какое сейчас время суток.
Будем считать, что если введено число от 5 до 10, то это утро, от 11 до 17, то день, с 18 до 22 – вечер, с 23 до 4 – ночь. Предусмотрите, что пользователь может ввести неверное число или вообще слово. Тогда ему стоит написать: Ошибка.
Не забудьте, что в данной задаче числа – это тоже строки.
Формат ввода
Вводится строка.
Формат вывода
Если введено число от 5 до 10, то вывести Утро, от 11 до 17, то День, с 18 до 22 – Вечер, с 23 до 4 – Ночь.
Если введено неверное число или слово, то вывести: Ошибка.
Answers & Comments
var
s:string[2];
r,c:integer;
begin
readln(s);
val(s,c,r);
if (r<>0) or (c>24) or (c<0) then
begin
writeln('Error');
exit;
end
else
case c of
5..10: writeln('ytro');
11..17: writeln('den');
18..22: writeln('vecher')
else writeln('noch');
end;
end.