Помогите написать программу на Паскале 1.написать функцию,подсчитывающую количество единиц в числе и с её помощью определить,в каком из двух чисел единиц больше.
function one(s: string): integer; var i, c: integer; begin c := 0; for i := 1 to length(s) do if (s[i] = '1') then c := c + 1; result := c; end;
begin writeln('Введите первое число:'); readln(s); writeln('Введите второе число:'); readln(s2); if(one(s) > one(s2)) then write('В первом числе больше единиц') else write('Во втором числе больше единиц'); end.
Answers & Comments
Verified answer
Vars, s2: string;
function one(s: string): integer;
var i, c: integer;
begin
c := 0;
for i := 1 to length(s) do
if (s[i] = '1') then c := c + 1;
result := c;
end;
begin
writeln('Введите первое число:');
readln(s);
writeln('Введите второе число:');
readln(s2);
if(one(s) > one(s2)) then write('В первом числе больше единиц')
else write('Во втором числе больше единиц');
end.