Помогите, пожалуйста, с информатикой. Нужно составить программу которая удалит из текста все цифры( использование pos,copy,delete,insert)
Answers & Comments
Ivan10353for i:=1 to length(s) doif s[i] in ['1'..'9'] then sum:=sum+ord(s[i])-48;//здесь ноли не считаем, от них сумма не меняетсяwriteln('Сумма цифр в тексте='sum);if sum>5 then begin for i:=lengrh(s) downto 1 do if s[i] in ['0'..'9'] then delete(s,i,1); write(s); endelse write('Цифры не удаляются!');
Answers & Comments