Ребята, это срочно! Составить программу, которая определяет является ли введенное слово словом-перевертышем ( использование pos,copy,delete,insert)
Answers & Comments
Ivan10353
Var s : string; i : integer; f : boolean; begin readln (s); writeln ('Тут ', length (s), ' символов'); f := true; for i := 1 to length (s) div 2 do if s[i] <> s[length (s) - i + 1] then f := false; writeln ('Это слово является перевертышем: ', f); //True/False end.//пишет истина или ложь
1 votes Thanks 1
merekekz
uses crt; var s,s1:string; i:integer; begin clrscr; writeln('vvеdite slovo'); readln(s); s1:=''; for i:=length(s) downto 1 do s1:=s1+s[i]; if s=s1 then writeln('Da') else writeln('NET'); readln end.
Answers & Comments
s : string;
i : integer;
f : boolean;
begin
readln (s);
writeln ('Тут ', length (s), ' символов');
f := true;
for i := 1 to length (s) div 2 do
if s[i] <> s[length (s) - i + 1] then f := false;
writeln ('Это слово является перевертышем: ', f); //True/False
end.//пишет истина или ложь
var
s,s1:string;
i:integer;
begin
clrscr;
writeln('vvеdite slovo');
readln(s);
s1:='';
for i:=length(s) downto 1 do
s1:=s1+s[i];
if s=s1 then writeln('Da')
else writeln('NET');
readln
end.