Home
О нас
Products
Services
Регистрация
Войти
Поиск
kelenad1999
@kelenad1999
July 2022
1
21
Report
Помогите составить программу, которая определяет три целых числа с клавиатуры, являются ли они сторонами прямоугольного треугольника.
Please enter comments
Please enter your name.
Please enter the correct email address.
Agree to
terms of service
You must agree before submitting.
Send
Answers & Comments
cccc1808
var
a,b,c,g : integer;
// a,b,c - стороны
begin
readln (a,b,c);
// g - находим гипотенузу (наибольшее из чисел)
if a > b then
begin
if a > c then
g := a
else
g := c
end
else
if b > c
then
g := b
else
g := c;
// Если треугольник прямоугольный, то
// сумма квадратов катетов равна квадрату гипотенузы
if (sqr (a) + sqr (b) = sqr(g))
or (sqr (a) + sqr (c) = sqr(g)) then
writeln ('Yes')
else writeln ('No');
end.
0 votes
Thanks 0
More Questions From This User
See All
kelenad1999
August 2022 | 0 Ответы
Помогите составить программу, которая посчитает сумму натуральных чисел из проме...
Answer
kelenad1999
August 2022 | 0 Ответы
Привести примеры формул, в которых кислород является окислителем, в которых восс...
Answer
kelenad1999
August 2022 | 0 Ответы
Помогите решить систему уравнений, пожалуйста. 9x^2-4y^2-24x-12y+7=0, 3|x-1|+2y+...
Answer
kelenad1999
August 2022 | 0 Ответы
Помогите пожалуйста написать программу, с помощью которой можно найти наименьшее...
Answer
kelenad1999
August 2022 | 0 Ответы
С помощью сокращенной формы оператора условия найти наименьшее из четырех заданн...
Answer
kelenad1999
August 2022 | 0 Ответы
Составить программу вычисления выражения: max(x^2+y^3, y^2+z^3)-4 Помогите пожа...
Answer
kelenad1999
July 2022 | 0 Ответы
Найти: i^i, где i-мнимая единица...
Answer
kelenad1999
July 2022 | 0 Ответы
Задается натуральное число q равное площади некоторого прямоугольника. Напишите ...
Answer
kelenad1999
July 2022 | 0 Ответы
Напишите программу поиска трехзначных чисел, таких, что сумма трех цифр на котор...
Answer
kelenad1999
July 2022 | 0 Ответы
Составить программу, проверяющую, является ли заданное натуральное число соверше...
Answer
рекомендуемые вопросы
rarrrrrrrr
August 2022 | 0 Ответы
о чем должны позаботиться в первую очередь взрослые при организационном вывозе н...
danilarsentev
August 2022 | 0 Ответы
Есть два станка на которых выпускают одинаковые запчасти один производит a запча...
myachina8
August 2022 | 0 Ответы
Найти по графику отношение V3:V1. В ответах написано 9, но нужно решение...
ydpmn7cn6w
August 2022 | 0 Ответы
Choose the correct preposition: 1.I am fond (out,of,from) literature. 2.where ar...
millermilena658
August 2022 | 0 Ответы
Определите Как создавалась и кто создавал арабское государство в крации...
MrZooM222
August 2022 | 0 Ответы
Ч. Айтманов в рассказе "Красное яблоко" использует метод рассказ в рассказе. Опи...
timobila47
August 2022 | 0 Ответы
каково было назначение каждой из частей византийского храма? помогите пожалуйста...
ivanyyaremkiv
August 2022 | 0 Ответы
moment. 6....
Участник Знаний
August 2022 | 0 Ответы
Пожалуйста!!!!!!!!!!!!...
sarvinozwakirjanova
August 2022 | 0 Ответы
помогите пожалусто пж...
×
Report "Помогите составить программу, которая определяет три целых числа с клавиатуры, я..."
Your name
Email
Reason
-Select Reason-
Pornographic
Defamatory
Illegal/Unlawful
Spam
Other Terms Of Service Violation
File a copyright complaint
Description
Helpful Links
О нас
Политика конфиденциальности
Правила и условия
Copyright
Контакты
Helpful Social
Get monthly updates
Submit
Copyright © 2025 SCHOLAR.TIPS - All rights reserved.
Answers & Comments
a,b,c,g : integer;
// a,b,c - стороны
begin
readln (a,b,c);
// g - находим гипотенузу (наибольшее из чисел)
if a > b then
begin
if a > c then
g := a
else
g := c
end
else
if b > c
then
g := b
else
g := c;
// Если треугольник прямоугольный, то
// сумма квадратов катетов равна квадрату гипотенузы
if (sqr (a) + sqr (b) = sqr(g))
or (sqr (a) + sqr (c) = sqr(g)) then
writeln ('Yes')
else writeln ('No');
end.