Помогите составить программу, которая посчитает сумму натуральных чисел из промежутка от 1 до 100, которые делятся на 17 и сумма цифр, которых не превышает 7. В Паскале.
{сумма натуральных чисел из промежутка от 1 до 100, которые делятся на 17 и сумма цифр, которых не превышает 7. Можно перебором} var i,s:integer; begin s:=0; for i:=1 to 100 do if (i mod 17=0) and (i div 10 + i mod 10<7) then s:=s+i; writeln(s); end. {результат 51}
{ Можно оптимизировать в цикле изменив for i:=1 to 100 do на for i:=17 to 100 do}
{2 вариантө оптимальнее - перебираем только числа кратные 17] var i,s:integer; begin s:=0; i:=17; while i<=100 do begin if (i div 10 + i mod 10<7) then s:=s+i; i:=i+17; end; writeln(s); end.
Answers & Comments
Verified answer
{сумма натуральных чисел из промежутка от 1 до 100,которые делятся на 17 и сумма цифр, которых не
превышает 7. Можно перебором}
var i,s:integer;
begin
s:=0;
for i:=1 to 100 do
if (i mod 17=0) and (i div 10 + i mod 10<7) then
s:=s+i;
writeln(s);
end.
{результат 51}
{
Можно оптимизировать
в цикле изменив for i:=1 to 100 do
на
for i:=17 to 100 do}
{2 вариантө оптимальнее - перебираем только числа кратные 17]
var i,s:integer;
begin
s:=0; i:=17;
while i<=100 do
begin
if (i div 10 + i mod 10<7) then
s:=s+i;
i:=i+17;
end;
writeln(s);
end.