с клавиатуры вводетьмя массиа из n целых чисел,составить программу и вывести на экран все элементы массива.которые стгят на не четных номерах и найти их сумму.
Answers & Comments
NiGhtWolFsconst n=5; var a:array[1..n] of integer; i,p:integer; begin for i:=1 to n do begin write ('Введите ',i,' элемент массива: '); readln (a[i]); end; WRITELN; write ('Массив: '); for i:=1 to n do if i mod 2 <> 0 then begin write (a[i],' '); p:=p+a[i]; end; WRITELN; write ('Сумма = ',p); end.
Answers & Comments
var a:array[1..n] of integer;
i,p:integer;
begin
for i:=1 to n do
begin
write ('Введите ',i,' элемент массива: ');
readln (a[i]);
end;
WRITELN;
write ('Массив: ');
for i:=1 to n do
if i mod 2 <> 0 then
begin
write (a[i],' ');
p:=p+a[i];
end;
WRITELN;
write ('Сумма = ',p);
end.