составить графическую схему алгоритма и написать программу с организацией ввода-вывода с помощью текстовых файлов. В каждой задаче задается квадратная матрица NxN. Программа должна осуществлять ввод и печать исходной матрицы и возможно, дополнительных данных, произвести необходимые действия и напечатать результаты. Подсчитать общее количество чисел, меньших заданного А, и чисел, больших заданного В среди элементов, находящихся ниже побочной диагонали.
Copyright © 2024 SCHOLAR.TIPS - All rights reserved.
Answers & Comments
var a:array[1..100,1..100]of integer;
i,j,c,b,n,k:integer;
begin
readln(n);
readln(c,b);
for i:=1 to n do for j:=1 to n do a[i,j]:=random(9)+1;
for i:=1 to n do begin for j:=1 to n do write(a[i,j],' '); if j=n then writeln; end;
writeln;
for i:=1 to n do
for j:=1 to n do
if (i>n-j+1) or (j<n-i+1) then if (a[i,j]<=c) and (a[i,j]>=b) then inc(k);
writeln(k);
end.