Составить программу на языке Паскаль для решения следующей задачи:
Дан одномерный массив. Замените все отрицательные элементы массива их квадратами, положительные элементы оставьте без изменения. Входные данные для размерности массива и значения элементов массива задайте самостоятельно.
На проверку нужно прислать текст кода программы, результат работы кода в виде скриншота окна программы с отображением кода и полученного результата.
Answers & Comments
var
arr : array[1..10] of integer;
begin
randomize;
write('Исходный массив: ');
for var i := 1 to 10 do
begin
arr[i] := random(-10, 10);
write(arr[i], ' ');
end;
for var i := 1 to 10 do
begin
if arr[i] < 0 then
arr[i] := arr[i] * arr[i];
end;
writeln;
write('Изменённый массив: ');
for var i := 1 to 10 do
begin
write(arr[i], ' ');
end;
end.