Составить программу в PASCAL. 1. В последовательности чисел подсчитать произведение чисел, кратных 3.
Answers & Comments
Hasl1337
Var x, sum: integer; begin sum := 1; writeln('Введите последовтельность чисел.', #10, '0 - остановить программу, получить результат.'); repeat readln(x); if(x mod 3 = 0) and (x <> 0) then sum := sum * x; until(x = 0); writeln('Произведение числе кратных 3: ', sum); end.
Answers & Comments
begin
sum := 1;
writeln('Введите последовтельность чисел.', #10, '0 - остановить программу, получить результат.');
repeat
readln(x);
if(x mod 3 = 0) and (x <> 0) then sum := sum * x;
until(x = 0);
writeln('Произведение числе кратных 3: ', sum);
end.