Составьте программу, которая заполняет массив а(1..10) случайными целыми числами в диапазоне от 1 до 100 , затем меняет местами максимальный и минимальный элементы. выведите на экран исходный и полученый массивы
Var i,min,max:integer; a:array[1..10] of integer; begin min:=100; max:=0; Randomize; for i:=1 to 10 do begin a[i]:=random(101); write(a[i],' '); if (a[i] > max) then max:=a[i]; if (a[i] < min) then min:=a[i]; end; writeln(''); for i:=1 to 10 do begin if a[i] = max then a[i]:=min else if a[i] = min then a[i]:=max; write(a[i],' ');end;
Soqwa
играй хотя бы честно, зачем подбивать кого-то поставить тебе лучший ответ и так далее?? Основная цель проекта - не набивать стату, а помогать людям!
archery
я просто им напоминаю, а то они часто завтыкивают выбрать лучший ответ, а мне не хватает лучших ответов для статуса
Soqwa
скажи, ты пришел на проект чтобы набить стату или чтобы помочь кому-то?
archery
чтоб порешать задачки и развлечься плюс статус если не в напряг
archery
я сомневаюсь что решением можно помочь комуто, для этого надо не решать а помочь решить - это разные вещи
archery
так что если мы соревнуемся в эстетике алгоритмов так почему бы и статус не собрать?
Soqwa
я согласен.. однако проект нацелен именно на РЕШЕНИЕ заданий, которые требуются.. однако, нечестно подбивать людей ставить лучшим ответ именно твой! Да, не спорю, забывают и часто, но ведь можно напомнить, а не трезвонить "Выбери меня"
Answers & Comments
n = 10;
var
i, min, max: integer;
a: array[1..n] of integer;
begin
min := 1; max := 1;
for i := 1 to n do
begin
a[i] := random(101);
write(a[i]:4);
if (a[i] > a[max]) then
max := i;
if (a[i] < a[min]) then
min := i;
end;
i := a[max];
a[max] := a[min];
a[min] := i;
writeln();
for i := 1 to n do
write(a[i]:4);
end.
Verified answer
Var i,min,max:integer;a:array[1..10] of integer;
begin
min:=100;
max:=0;
Randomize;
for i:=1 to 10 do
begin
a[i]:=random(101);
write(a[i],' ');
if (a[i] > max) then max:=a[i]; if (a[i] < min) then min:=a[i];
end;
writeln('');
for i:=1 to 10 do
begin
if a[i] = max then a[i]:=min else if a[i] = min then a[i]:=max;
write(a[i],' ');end;
end.