составьте программу которая заполняет массив а(1..10) случайными целыми числами в диапазоне от 1 до 10, затем вычисляет среднее арифметическое элементов массива
Answers & Comments
karimPhoenix uses crt; const n=10; var i:integer; sum,sred:real; mas:array [1..n] of integer; begin for i:=1 to n do begin mas[i]:=random(10); end; for i:=1 to n do sum:=sum+mas[i]; sred:=sum/n; write('srednee ravno ',sred); read; end. вот))) если хочешь могу написать чтобы выводила и сами цифры массива, чтобы потом можно было наглядно проверить все)))
1 votes Thanks 1
karimPhoenix
uses crt; const n=10; var i:integer; sum,sred:real; mas:array [1..n] of integer; begin i:=1; while i<=n do begin mas[i]:=random(10); i:=i+1; end; i:=1; while i<=n do begin sum:=sum+mas[i]; i:=i+1; end; sred:=sum/n; write('srednee ravno ',sred); read; end.
karimPhoenix
можно еще проще без цикла с меткой и оператором if))))
karimPhoenix
вот самое простое что смог придумать(хотя учить массив и не знать циклов......)
karimPhoenix
uses crt; const n=10; var i:integer; sum,sred:real; mas:array [1..n] of integer; label 1; label 2; begin i:=0; 1:i:=i+1; if i<=n then begin mas[i]:=random(10); goto 1; end; i:=0; 2:i:=i+1; if i<=n then begin sum:=sum+mas[i]; goto 2; end; sred:=sum/n; write('srednee ravno ',sred); read; end.
Tanya28064
вот отлично работает второе. но надо что бы оно ещё показывало числа которых считает среднее орифметичское) а так огромное спасибо!!!
karimPhoenix
uses crt; const n=10; var i:integer; sum,sred:real; mas:array [1..n] of integer; begin i:=1; while i<=n do begin mas[i]:=random(10); i:=i+1; end; i:=1; while i<=n do begin write(mas[i],' '); i:=i+1; end; i:=1; while i<=n do begin sum:=sum+mas[i]; i:=i+1; end; sred:=sum/n; write('srednee ravno ',sred); read; end.
Tanya28064
СУПЕР! СПАСИБО! ВЫ ОЧЕНЬ ОЧЕНЬ ПОМОГЛИ!
Answers & Comments
uses crt;
const n=10;
var
i:integer;
sum,sred:real;
mas:array [1..n] of integer;
begin
for i:=1 to n do
begin
mas[i]:=random(10);
end;
for i:=1 to n do
sum:=sum+mas[i];
sred:=sum/n;
write('srednee ravno ',sred);
read;
end.
вот))) если хочешь могу написать чтобы выводила и сами цифры массива, чтобы потом можно было наглядно проверить все)))
const n=10;
var
i:integer;
sum,sred:real;
mas:array [1..n] of integer;
begin
i:=1;
while i<=n do
begin
mas[i]:=random(10);
i:=i+1;
end;
i:=1;
while i<=n do
begin
sum:=sum+mas[i];
i:=i+1;
end;
sred:=sum/n;
write('srednee ravno ',sred);
read;
end.
const n=10;
var
i:integer;
sum,sred:real;
mas:array [1..n] of integer;
label 1; label 2;
begin
i:=0;
1:i:=i+1;
if i<=n then
begin
mas[i]:=random(10);
goto 1;
end;
i:=0;
2:i:=i+1;
if i<=n then
begin
sum:=sum+mas[i];
goto 2;
end;
sred:=sum/n;
write('srednee ravno ',sred);
read;
end.
а так огромное спасибо!!!
const n=10;
var
i:integer;
sum,sred:real;
mas:array [1..n] of integer;
begin
i:=1;
while i<=n do
begin
mas[i]:=random(10);
i:=i+1;
end;
i:=1;
while i<=n do
begin
write(mas[i],' ');
i:=i+1;
end;
i:=1;
while i<=n do
begin
sum:=sum+mas[i];
i:=i+1;
end;
sred:=sum/n;
write('srednee ravno ',sred);
read;
end.