Составьте программу,которая заполняет массив a[1..10] случайными числами в диапазоне от 0 до 10,затем первый элемент меняет местами с максимальным элементом.Выведите на экран исходный и полученный массивы.
Answers & Comments
MaxKrivich
Program Project2; {$APPTYPE CONSOLE} uses SysUtils; var a:array [0..9] of integer; i,max,indx,tmp:Integer; begin Randomize; for i:=0 to 9 do a[i]:=Random(10); for i:=0 to 9 do write(a[i]:3); Writeln; max:=a[0]; indx:=0; for i:=0 to 9 do if a[i]>max then begin max:=a[i]; indx:=i; end; tmp:=a[0]; a[0]:=max; a[indx]:=tmp; for i:=0 to 9 do write(a[i]:3); readln; end.
Answers & Comments
{$APPTYPE CONSOLE}
uses SysUtils;
var a:array [0..9] of integer; i,max,indx,tmp:Integer;
begin
Randomize;
for i:=0 to 9 do
a[i]:=Random(10);
for i:=0 to 9 do
write(a[i]:3);
Writeln;
max:=a[0];
indx:=0;
for i:=0 to 9 do
if a[i]>max then
begin
max:=a[i];
indx:=i;
end;
tmp:=a[0];
a[0]:=max;
a[indx]:=tmp;
for i:=0 to 9 do
write(a[i]:3);
readln;
end.