Составьте программу,которая заполняет массив a[1..10] случайными числами в диапазоне от 0 до 10,затем первый элемент меняет местами с максимальным элементом.Выведите на экран исходный и полученный массивы.
Answers & Comments
vello
Program asd; var a,b,c,i:integer; ar:array[1..11] of integer; begin for i:=1 to 10 do begin a:=random(10); ar[i]:=a; end; for i:=1 to 10 do write(ar[i],' '); b:=ar[1]; for i := 2 to 10 do if ar[i] > b then begin b:=ar[i]; c:=i; end; ar[c]:=ar[1]; ar[1]:=b; writeln(); for i:=1 to 10 do write(ar[i],' '); end.
Answers & Comments
var
a,b,c,i:integer;
ar:array[1..11] of integer;
begin
for i:=1 to 10 do begin
a:=random(10);
ar[i]:=a;
end;
for i:=1 to 10 do write(ar[i],' ');
b:=ar[1];
for i := 2 to 10 do
if ar[i] > b then begin b:=ar[i];
c:=i;
end;
ar[c]:=ar[1];
ar[1]:=b;
writeln();
for i:=1 to 10 do write(ar[i],' ');
end.