СРОЧНО! Паскаль!
1. Написать программу, которая подсчитывает количество элементов, четных и оканчивающихся на 6, в массиве целых чисел. Количество элементов массива равно N. Массив заполнить случайными числами в интервале [20,80). Если таких чисел нет, напечатать «Нет».
2. Написать программу, которая подсчитывает количество пар элементов в массиве, в которых каждый элемент равен второму в паре. В массиве 10 элементов, массив заполняется с помощью случайных чисел из интервала (0, 100).
Пример работы программы:
Входные данные Выходные данные Комментарий
5 5 6 7 7 8 9 2 (первая пара 5 5, вторая – 7 7)
5 5 5 7 7 9 9 4 (первая пара 5 5, вторая 5 5, третья 7 7, четвертая 9 9)
1 2 3 4 5 6 7 8 нет Нет ни одной пары
Answers & Comments
var a:array[1..N] of integer;
i, k: integer;
begin
k:=0;
for i:=1 to N do
a[i]:= random((80) - 20);
if (a[i] mod 10 = 6) and (a[i] mod 2 = 0) then
k:=k+1;
end;
writeln(k);
2)const N = 10;
var a:array[1..N] of integer;
i, k: integer;
begin
k:=0;
for i:=1 to N do
a[i]:=random(100);
for i:=1 to N-1 do
if a[i] = a[i+1] then
k:=k+1;
writeln(k);
end.