Срочно,информатика (решить все через while)
1.Составьте и отдадите программу,определяющую максимальное из всех введенных вами чисел.(Пусть признаком конца ввода чисел является введённое число 0)
2Найти наибольшее и наименьшее значение функции y=3x^2+x-4,если на заданном интервале [a,b] x изменяется с шагом 0,1.
3.Составьте программу определения наибольшего общего делителя двух натуральных чисел
Answers & Comments
program p1;
var max, a: integer;
begin max := 0; writeln('Введите число'); readln(a); while a <> 0 do begin if a > max then max := a; readln(a); end; writeln(max);end.