СРОЧНО!МНОГО БАЛЛОВ!!Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 6 и оканчивающихся на 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести одно число: количество чисел, кратных 6 и оканчивающихся на 4.
INPUT 3,24,25,54
RESULT2
Answers & Comments
#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
int main()
{
size_t size, value, count;
cin >> size;
vector<int> v;
for (size_t i = 0; i < size; ++i) {
cin >> value;
v.push_back(value);
}
count = count_if(v.cbegin(), v.cend(), [](const int& i) { return (i % 6 == 0) | (i
% 10 == 4); });
cout << count;
}