Всем привет.

Вообщем, вот задача и к ней необходимо написать программу(Pascal). Код программы будет ниже.Нужно проверить его на ошибки и дать коментарии к коду. Если код неправильный прошу подкорректировать. Буду очень признателен. Заранее спасибо.

Задача:

Дана последовательность из n действительных чисел (n <= 100). Написать программу для подсчета суммы этих чисел.

Код программы:

var massiv: array [1..100] of real;
sum: real;
n,i: integer;
begin
clrscr;
writeln ('Введите количество чисел');
readln (n);

for i:=1 to n do
begin
writeln ('Введите ',i,'-ое число');
readln (massiv [i]);
end;

sum:=0;
for i:=1 to n do
sum:= sum + massiv [i];

writeln ('Сумма последовательности равна ', sum:0:4);
readln;
end.
Please enter comments
Please enter your name.
Please enter the correct email address.
You must agree before submitting.

Answers & Comments


Copyright © 2024 SCHOLAR.TIPS - All rights reserved.