задача на c++
Требуется написать программу, которая определяет цифры исходного четырёхзначного числа x и выводит их на экран.
Формат входных данных
Входной поток содержит целое число x (1000≤x≤9999)
Формат выходных данных
Выведите цифры числа xx по одному в строке, в следующем порядке: тысячи, сотни, десятки и затем единицы.
Answers & Comments
using namespace std;
int main()
{
int a, b;
cout << "a = ", cin >> a, cout << "\n";
b = a/1000;
cout << b << "\n";
b = a/100 % 10;
cout << b << "\n";
b = a % 100 / 10;
cout << b << "\n";
b = a % 10;
cout << b << "\n";
return 0;
}
Пример:
a = 7052
7
0
5
2
Verified answer
///////////////////////////////////////////////////////