Решите, пожалуйста, задачу на языке PascalABC.net. ДАЮ 100 БАЛЛОВ!!!
Три толстяка решили поспорить: кто из них самый тяжелый. После взвешивания оказалось, что их масса соответственно M1, M2 и M3 килограмм. Считается, что масса толстяка должна быть не менее 94 и не более 727 килограмм.
Помогите определить массу самого тяжелого из них, либо выяснить, что была допущена ошибка при взвешивании.
Входные данные
Входной файл INPUT.TXT содержит три целых числа M1, M2 и M3, разделенные пробелом. Все числа целые и не превосходят 10 000 по абсолютной величине.
Выходные данные
В выходной файл OUTPUT.TXT выведите массу самого тяжелого толстяка в случае корректного взвешивания, либо слово «Error» в противном случае.
Answers & Comments
var
M1, M2, M3: Integer;
begin
Reset(INPUT, 'INPUT.TXT');
ReadLn(M1, M2, M3);
Close(INPUT);
if (M1 >= 94) and (M1 <= 727) and (M2 >= 94) and (M2 <= 727) and (M3 >= 94) and (M3 <= 727) then
begin
// Определение массы самого тяжелого толстяка
if (M1 >= M2) and (M1 >= M3) then
// M1 является самой тяжелой массой
WriteLn(OUTPUT, M1)
else if (M2 >= M1) and (M2 >= M3) then
// M2 является самой тяжелой массой
WriteLn(OUTPUT, M2)
else
// M3 является самой тяжелой массой
WriteLn(OUTPUT, M3);
end
else
begin
// Вывод "Error" в случае ошибки
WriteLn(OUTPUT, 'Error');
end;
Close(OUTPUT);
end.