PASCALABC.NET
Магазин обслужил за день 200 покупателей, каждый из которых потратил на покупки от 10 до 1100 р. Покупателям с суммой покупки больше 1000 р. магазин подарил скидочные карты. Составьте программу, вычисляющую дневную выручку магазина, среднюю стоимость покупки и количество выданных за день скидочных карт.
Answers & Comments
Ответ:
var
i, price, cardCount :integer;
midPrice : real;
begin
Randomize;
cardCount := 0;
writeln('Покупки в магазине:');
for i:=1 to 200 do begin
price := random(10, 1100);
if price > 1000 then inc(cardCount);
midPrice := midPrice + price;
print(price);
end;
writeln();
writeln('Выручка магазина ='+midPrice);
writeln('Средняя стоимость покупки ='+midPrice/200);
writeln('Количество выданных за день скидочных карт ='+cardCount);
end