Помогите, пожалуйста! Через паскаль! Тема: «Поиск наибольшего или наименьшего элемента массива»
Написать программу, которая запрашивает у пользователя строку и заменяет в ней все пробелы знаками подчеркивания '_'
Не использовать: const, count и другие, которые не по теме!
Answers & Comments
s: String;
begin
writeln('Введите текст');
readln(s);
for i:=1 to Length(s) do
begin
if s[i]=' ' then s[i]:='_';
end;
writeln(s);
end.
g: string;
i: byte;
begin
readln(g);
i := 1;
while g[i] = ' ' do delete(g,i,1);
i := length(g);
while g[i] = ' ' do begin delete(g,i,1); i := i - 1 end;
i := 1;
while i <= length(g) do begin
if g[i] = ' ' then
if g[i-1] = '*' then begin
delete(g,i,1);
i := i - 1;
end
else begin
delete(g,i,1);
insert('_',g,i);
end;
inc(i);
end;
writeln(g);
end.