Пожалуйста, помогите!
Написать программу на языке Паскаль, которая запрашивает у пользователя 10 чисел и заполняет полученными от пользователя числами массив.
Далее программа должна вывести на экран индексы и значения тех элементов массива, в которых содержатся положительные числа.
Например:
Пользователь ввел числа 1, -2, -3, 4, 5, -6, 8, 100, -200, 45
Программа должна вывести на экран:
1 - 1
4 - 4
5 - 5
7 - 8
8 - 100
10 – 45
Не в коем случае не используй const, Count и т.д. Обыкновенным способам по возможности.
Answers & Comments
Verified answer
Vara: array[1..10] of integer;
i: integer;
begin
for i := 1 to 10 do
read(a[i]);
for i := 1 to 10 do
if a[i] > 0 then
writeln(i, ' - ', a[i])
end.