Помогите пожалуйста!!!
Срочно!!!
напишите программу которая для последовательности натуральных чисел выводит сумму всех входящих в последовательность чисел, меньших 50, но больших 10.
Количество чисел не превышает 100. Введенные числа не превышают 300. Программа должна вывести одно число-сумму всех входящих в последовательность чисел, меньших 50, но больших 10
Answers & Comments
a,i,sum : integer;
begin
for i:=1 to 10 do begin
read(a);
if (a>10) and (a<50) then sum:=sum +a;
end;
write(sum);
end.
class Program
{
static void Main(string[] args)
{
int a = 0, summa = 0;
for (int i = 0; i <= 100; i++)
{
a = Convert.ToInt32(Console.ReadLine());
if (a > 10 && a < 50)
{
summa += a;
}
else if (a == 0)
{
break;
}
}
Console.WriteLine(summa);
Console.ReadLine();
}
}