Составьте программу, которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 1 до 10, затем меняет местами первый элемент со вторым, третий с четвертым и т. д. Выведите на экран исходный и полученный массивы. Program shist;
Var a:array[1..10] of integer;
i, z, max: integer;
Begin
For i:=1 to 10 do
a[i]:=Random(11);
writeln ('Исходный массив');
For i:=1 to 10 do
write (a[i], ' ');
writeln;
For i:=1 to 10 do
if i mod 2 <> 0 then
begin
z:=a[i];
a[i]:=a[i+1];
a[i+1]:=z;
end;
writeln('Полученный массив');
For i:=1 to 10 do
write (a[i], ' ');
End.
Отныне эта программа является правильной и может использоваться как памятка.
Please enter comments
Please enter your name.
Please enter the correct email address.
You must agree before submitting.
More Questions From This User See All

Copyright © 2025 SCHOLAR.TIPS - All rights reserved.