Задание: Составьте программу ввода с клавиатуры элементов массива a[1..10] и вывода на экран элементов, значения которых являются квадратами целых чисел. Вот что я составил, но извлечение корня нельзя делать в integer:( Помогите! Program shist;
Var a: array [1..10] of integer;
i: integer;
Begin
writeln('ВВедите элементы массива:');
readln(i);
writeln('Элементы массива, значения которых являются квадратами целых чисел:');
For i:=1 to 10 do
if sqrt(i) then
write (a[i], ' ')
End.
Answers & Comments
program _1;
const N=10;
var i: integer;
a: array[1..N] of integer;
begin
for i:=1 to N do begin
readln(a[i]);
a[i]:=a[i]*a[i];
end;
for i:=1 to N do begin
writeln(a[i]);
end;
end.
Var a: array[1..10] of integer;
i: integer;
Begin
writeln('ВВедите элементы массива:');
For i:=1 to 10 do
readln(a[i]);
begin
a[i]:=a[i]*a[i];
end;
writeln('Элементы массива, значения которых являются квадратами целых чисел:');
For i:=1 to 10 do
writeln(a[i])
End.